Can't update Drupal 8.2.1 core

On a new, fresh installation of Drupal 8.2.1 when checking for available updates the following error message is given: drupal 8.2.1 Failed to get available update data. Includes: Enabled: Automated Cron, Bartik, Block, Breakpoint, CKEditor, Classy, Color, Comment, Configuration Manager, Contact, Contextual Links, Custom Block,[…]