D7 Site With Amazing Bugs

I believe that I have an error message coming from core that I myself am not able to trace or repair.  However, I think that it is indicative of a deeper problem as my  drupal 7 site is just overall behaving weirdly.  This might be several problems or one big problem that I don’t understand.  

1.)  Whenever I make any piece of new content I instantly receive the error message below (6 pieces of content): 

  • Notice: Trying to get property of non-object in node_page_title() (line 2200 of /vagrant/public_html/example.org/modules/node/node.module).
  • Notice: Trying to get property of non-object in node_page_title() (line 2200 of /vagrant/public_html/example.org/modules/node/node.module).
  • Notice: Trying to get property of non-object in node_page_title() (line 2200 of /vagrant/public_html/example.org/modules/node/node.module).
  • Notice: Trying to get property of non-object in node_page_title() (line 2200 of /vagrant/public_html/example.org/modules/node/node.module).
  • Notice: Trying to get property of non-object in node_page_title() (line 2200 of /vagrant/public_html/example.org/modules/node/node.module).
  • Notice: Trying to get property of non-object in node_page_title() (line 2200 of /vagrant/public_html/example.org/modules/node/node.module).

2.) The only way to get rid of the error messages is to go under `/admin/structure/menu/manage/main-menu` and physically delete blank menu entries  

3.) I have completely uninstalled menu-link-node module and menu-block module but the error still appears. I disabled every module related to the menu, but still reproduced the error

4.) Major Problem for a blog site:   Every time I create new piece of written content and save it… drupal saves it as –blank–  .  From the second time that I write and save content for the same page that was previously created, everything behaves as designed. (Nope, not fun discovering this problem.

4.)  My admin overlay stopped working (plenty of memory), so I disabled it.

5.) even though I disabled and uninstalled the Book module, I am seeing the “Add Book Page” option under add content options and Book is still listed as a content type.  I can still edit the content and add book content, despite having completely uninstalled the book module. (cleared cache, reload, etc.)

I have never seen a drupal 7 site act this buggy all at once…. anyone have any idea what’s going on? Are these all separate problems or a deeper single issue that I am missing?

thanks

Drupal version: 


Source: https://www.drupal.org/taxonomy/term/22/feed