d8 – composer outdated – produces a list – update doesn't update

On a D8 site, when I run the composer outdated command to check for components that need updating, composer produces a list, as follows:

php composer.phar outdated

doctrine/annotations v1.2.7 v1.3.1 Docblock Annotations Parser
doctrine/common v2.5.3 v2.7.2 Common Library for Doctrine projects
drupal/clientside_validation 1.0.0-rc1 1.0.0-rc3 Add client side validation to forms.
drupal/superfish 1.0.0-rc4 1.0.0-rc5 Adds jQuery Superfish plugin to menu blocks.
egulias/email-validator 1.2.13 2.1.1 A library for validating emails
jcalderonzumba/gastonjs v1.0.3 v1.1.0 PhantomJS API based server for webpage automation
phpunit/php-code-coverage 2.2.4 4.0.5 Library that provides collection, processing, and rendering functionality for PHP code cove…
phpunit/phpunit 4.8.31 5.7.5 The PHP Unit Testing framework.
phpunit/phpunit-mock-objects 2.3.8 3.4.3 Mock Object library for PHPUnit
sebastian/environment 1.3.8 2.0.0 Provides functionality to handle HHVM/PHP environments
sebastian/exporter 1.2.2 2.0.0 Provides the functionality to export PHP variables for visualization
sebastian/recursion-context 1.0.2 2.0.0 Provides functionality to recursively process PHP variables
sebastian/version 1.0.6 2.0.1 Library that helps with managing the version number of Git-hosted PHP projects
symfony/class-loader v2.8.16 v3.2.2 Symfony ClassLoader Component
symfony/console v2.8.16 v3.2.2 Symfony Console Component
symfony/css-selector v2.8.16 v3.2.2 Symfony CssSelector Component
symfony/debug v2.8.16 v3.2.2 Symfony Debug Component
symfony/dependency-injection v2.8.16 v3.2.2 Symfony DependencyInjection Component
symfony/event-dispatcher v2.8.16 v3.2.2 Symfony EventDispatcher Component
symfony/http-foundation v2.8.16 v3.2.2 Symfony HttpFoundation Component
symfony/http-kernel v2.8.16 v3.2.2 Symfony HttpKernel Component
symfony/process v2.8.16 v3.2.2 Symfony Process Component
symfony/psr-http-message-bridge v0.2 v1.0.0 PSR HTTP message bridge
symfony/routing v2.8.16 v3.2.2 Symfony Routing Component
symfony/serializer v2.8.16 v3.2.2 Symfony Serializer Component
symfony/translation v2.8.16 v3.2.2 Symfony Translation Component
symfony/validator v2.8.16 v3.2.2 Symfony Validator Component
symfony/yaml v2.8.16 v3.2.2 Symfony Yaml Component

—-

running composer update immediately after produces the following results:

php composer.phar update
Loading composer repositories with package information
Updating dependencies (including require-dev)
Nothing to install or update
Generating autoload files
> DrupalCoreComposerComposer::preAutoloadDump
> DrupalCoreComposerComposer::ensureHtaccess

—-

What does it mean when “outdated” indicates components that need updating, but the update command indicates that nothing needs to be updated?

What are the implications of this condition?

Drupal version: 


Source: https://www.drupal.org/taxonomy/term/21/feed