Drush gives "Command pm-enable needs a higher bootstrap level to run" messages

In the past I did the easy but not official way of installing Druapl 8 using Softaculous. After that I started using Composer to download modules and the Drush command php drush.php en (machine_name) to enable them. All was fine and good up to 8.3.7.

Now I am creating a new site the “proper” way, installing the complete Drupal package (including Drush and Drupal console) from drupal-composer/drupal-project. install.php was run from the browser and the very basic 8.4 site was up and running.

Using PuTTY I ran the composer require command to add a new module, and then like I used to I ran the Drush en command to enable that module. But now I am getting the following error:

Command pm-enable needs a higher bootstrap level to run - you will need to invoke drush from a more functional Drupal environment to run this command.

I’ve searched the web for this error message and nothing seems to apply to this situation. And since the site is already basically working, how much more of a “functional Drupal environment” does it need?

Some posts have said that the Drush command needs to be run in the root directory. I’ve tried the main root folder on the server for this particular website, the drupal-project folder (the docroot subfolder), its web subfolder, etc. No difference.

One additional odd thing I noticed: I checked out the composer.lock file for instances of drush/drush. The installed version appears to be 8.1.15. But in the drupal/core section there is this located between “require” and “replace”:

"conflict": {
      "drush/drush": "<8.1.10"
},

Is this somehow contributing to the problem?

Drupal version: 


Source: https://www.drupal.org/taxonomy/term/22/feed