On some "Releases" pages, "Install with Composer" version incorrect

For example, the Coder version 8.x-2.12 release page says:

Install with Composer: $ composer require 'drupal/coder:^2.12'

This should be:

Install with Composer: $ composer require 'drupal/coder:^8.2.12'

For some reason, the “8.” prefix of the version is omitted. I don’t know if this only affects the coder module, or if it affects all modules that use “7.” and “8.” version prefixes.


Source: https://www.drupal.org/project/issues/rss/infrastructure