search_api_solr 8.x-1.0-rc3

Release notes

This is the third release candidate of the Search API Solr Search 8.x-1.0. The minimum “officially supported” Solr version is still 4.5.1. The latest supported Solr version is 6.4.2.
Any newer Solr version might work for you, but there is a known issue at the moment, #2869529: Autocomplete (and spell checking) is broken on Solr 6.5.0, needs to be fixed in solarium lib .

This release only works in combination with search_api 8.x-1.1!

The most important change that happened during the beta phase was the introduction of SolrConnector classes that allow Solr providers to do their specific adjustments without hacking the Solr backend class anymore. Local and standard installations will be supported by this module out of the box. An corresponding upgrade path is included. For other installations you can check these issues:

If you update an existing installation, the first thing you should do is to deploy the latest Solr config files from the module’s solr-conf folder and afterwards delete all the data from the index and start a re-indexing process!

The basic API is considered complete now and the essential stuff works very well, but we still have incomplete features which will be addressed after the final release of 1.0:

Complete list of changes since rc2:

Download Size md5 hash
search_api_solr-8.x-1.0-rc3.tar.gz 187.76 KB 922e03c2c69c00d96a06ff63aa1ff1ea
search_api_solr-8.x-1.0-rc3.zip 238.11 KB 4fcaf3662427f709c65592b092fc630e
Last updated: 17 May 2017 at 12:43 UTC
Official release from tag: 
8.x-1.0-rc3
Core compatibility: 
Release type: 
Packaged Git sha1: 
d3db3c2e19d2057f6df9d3bad1c40187c3bfdf68


Source: https://www.drupal.org/taxonomy/term/7234/feed