unable to select "migrate ui" module

Trying to migrate from Drupal 7 to Drupal 8 and as per the instructions I need to have the “migrate ui” module enabled, but I just simply can not enable it. I can not tick that option. Please advise.

Thanks.

Drupal version: 


Source: https://www.drupal.org/taxonomy/term/1/feed