Update Core 8.3.6=> 8.45 with composer broken

Problem 1
- Conclusion: don't install drupal/core 8.4.5
- Conclusion: remove symfony/class-loader v2.8.32
- Installation request for drupal/core ~8.4.4 -> satisfiable by drupal/core[8.4.4, 8.4.5].
- Conclusion: don't install symfony/class-loader v2.8.32
- drupal/core 8.4.4 requires symfony/class-loader ~3.2.8 -> satisfiable by symfony/class-loader[v3.2.10, v3.2.11, v3.2.12, v3.2.13, v3.2.14, v3.2.8, v3.2.9].
- Can only install one of: symfony/class-loader[v3.2.10, v2.8.32].
- Can only install one of: symfony/class-loader[v3.2.11, v2.8.32].
- Can only install one of: symfony/class-loader[v3.2.12, v2.8.32].
- Can only install one of: symfony/class-loader[v3.2.13, v2.8.32].
- Can only install one of: symfony/class-loader[v3.2.14, v2.8.32].
- Can only install one of: symfony/class-loader[v3.2.8, v2.8.32].
- Can only install one of: symfony/class-loader[v3.2.9, v2.8.32].
- Installation request for symfony/class-loader (locked at v2.8.32) -> satisfiable by symfony/class-loader[v2.8.32].

 

When i run composer require 8.4.5.

I can’t remove my .lock cause my project use specific dev version of module.

Drupal version: 


Source: https://www.drupal.org/taxonomy/term/21/feed