Using AddToAny in View

Hi,

I have a content type “news-item” and a page “news”. In the view of news I get all nodes of type news-item and display them in a list.

What I want:
I want to have sharing icons on each news entry in that list but also in the node page itself [like /node/****].

What I did:
1. installed AddToAny Module
2. Enabled it
3. Added example code for Custom service icons from https://www.addtoany.com/buttons/customize/drupal/standalone_services [so I do for sure see anything]
4. Added AddToAny Link field to my view.

Result:
The Twitter, Facebook, Google Plus Links are displayed but don’t work. The “Any Service” Button from the addtoany works fine. Generated source:


    <span class="views-label views-label-addtoany-link">AddToAny link: </span>    <span class="field-content"><span class="a2a_kit a2a_kit_size_32 a2a_target addtoany_list" id="da2a_1">
      <a class="a2a_button_facebook">
    <img src="https://farm3.staticflickr.com/2863/12004329833_ddcd67ff4a_o.png" alt="Facebook" height="55" width="54" border="0">
</a>
<a class="a2a_button_twitter">
    <img src="https://farm3.staticflickr.com/2886/12004329883_8daa4af904_o.png" alt="Twitter" height="55" width="54" border="0">
</a>
<a class="a2a_button_google_plus">
    <img src="https://farm4.staticflickr.com/3774/12004033365_8965d86637_o.png" alt="Google+" height="55" width="54" border="0">
</a>
<a class="a2a_dd" href="https://www.addtoany.com/share">
    <img src="https://farm8.staticflickr.com/7326/12005120763_a44dc82111_o.png" alt="Share" height="55" width="54" border="0">
</a>
      <a class="a2a_dd addtoany_share_save" href="https://www.addtoany.com/share#url=https%3A%2F%2Fqudevwiki-test.phys.ethz.ch%2Fdrupal7%2Fnode%2F217750&amp;title=Strong%20Coupling%20Cavity%20QED%20with%20Gate-Defined%20Double%20Quantum%20Dots%20Enabled%20by%20a%20High%20Impedance%20Resonator"></a>
      
    </span>
    <script type="text/javascript">
<!--//--><![CDATA[//><!--
if(window.da2a)da2a.script_load();
//--><!]]>
</script></span>  

Question:
Problem 1: Why do the sharing buttons I get in the view – in the list of nodes – not work?
Problem 2: If I go to foo.com/node/***** there are no sharing buttons but if I edit the node and go to preview, they are there and work fine.

How do I solve this?

Drupal version: 


Source: https://www.drupal.org/taxonomy/term/22/feed